Информационная безопасность
[RU] switch to English


Дополнительная информация

  Ежедневная сводка ошибок в Web-приложениях (PHP, ASP, JSP, CGI, Perl )

  flashChat  4.7.8 Cross Site Scripting Vulnerability

  Wap Portal Serve 1.* <= Remote File Inclusion

  dvddb-0.6 media remote file include vuln.

  dvddb-0.6 media sql-inj. vuln.

From:stormhacker_(at)_hotmail.com <stormhacker_(at)_hotmail.com>
Date:5 февраля 2007 г.
Subject:flashChat 4.7.8 Cross Site Scripting Vulnerability

/*\ Flashchat 4.7.8 /*\

Date of written Advisory: February 04, 2007

Product: Flash Chat =< 4.7.8

Vendor: http://tufat.com/

Description:  flashChat is a highly customizable PHP/MySQL based chat room script that is easily integrated into a website and mimics IRC in it's command structure

Exploit(s) / Vulnerability(ies): flashChat is vulnerable to Cross Site Scripting in info.php when the 'add room' function is enabled, which is a default setting and therefore very common.  The follow block of code shows variables being displayed without any filtration:
<td><?$room['name']?></td>

PoC(s): create a new channel with the following in the title: <script>alert('test')</script> and use the "who's online" feature on the HTML login page.  This could obviously be used for cookie stealing and other malicious attacks.

Vendor Status:  Vendor was not informed before publication.

Solution: The vendor has yet to publish a solution for the exploit.  There is an unofficial patch on binaryloc's homepage.

Credits:
binaryloc

binaryloc[at]gmail[dot]com

http://binary.copyleftwriting.org

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород