Информационная безопасность
[RU] switch to English


Дополнительная информация

  Cводка уязвимостей безопасности в Web-приложениях (PHP, ASP, JSP, CGI, Perl)

  [SECURITY] [DSA 2091-1] New squirrelmail packages fix cross-site request forgery

  XSRF (CSRF) in Mystic

  XSS vulnerability in Mystic

  XSS vulnerability in Mystic

From:High-Tech Bridge Security Research <advisory_(at)_htbridge.ch>
Date:14 августа 2010 г.
Subject:SQL injection vulnerability in i-Web Suite

Vulnerability ID: HTB22543
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_i_web_suite.html
Product: i-Web Suite
Vendor: immediaC world wide Inc ( http://www.immediac.com/ )
Vulnerable Version: Current at 27.07.2010 and Probably Prior Versions
Vendor Notification: 27 July 2010
Vulnerability Type: SQL Injection
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response
Risk level: High
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/)

Vulnerability Details:
An attacker can disclose arbitrary local file content.

The vulnerability exists due to failure in the "default.asp" script to properly sanitize user-supplied input in multiple variables. An attacker can compromise the application, get configuration and password files content. Access to this information could lead attacker in launching further attacks against the target system.

Attacker can use browser to exploit this vulnerability. The following PoC is available:


http://host/default.asp?mn=1+SQL_CODE+
http://host/default.asp?mn=1.1+SQL_CODE+
http://host/default.asp?mn=1.1.1+SQL_CODE+
http://host/default.asp?mn=1.1&sfield=content.id&search=995+SQL_CODE
http://host/default.asp?mn=1.1&sfield=content.id+SQL_CODE&search=995

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород