Информационная безопасность
[RU] switch to English


Дополнительная информация

  DoS против libgd / PHP

From:MANDRIVA
Date:22 июля 2014 г.
Subject:[ MDVSA-2014:133 ] gd



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory                         MDVSA-2014:133
http://www.mandriva.com/en/support/security/
_______________________________________________________________________

Package : gd
Date    : July 10, 2014
Affected: Business Server 1.0
_______________________________________________________________________

Problem Description:

Updated gd and libgd packages fix security vulnerability:

The gdImageCreateFromXpm function in gdxpm.c in the gd image library
allows remote attackers to cause a denial of service (NULL pointer
dereference and application crash) via a crafted color table in an
XPM file (CVE-2014-2497).
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-2497
http://advisories.mageia.org/MGASA-2014-0288.html
_______________________________________________________________________

Updated Packages:

Mandriva Business Server 1/X86_64:
133d72d12a278f494662878dd8b8fafb  mbs1/x86_64/gd-utils-2.0.35-19.1.mbs1.x86_64.rpm
91c8a7f9053c2c335ea49bbb30bb21fc  mbs1/x86_64/lib64gd2-2.0.35-19.1.mbs1.x86_64.rpm
3422b3f8b50dc626be29096304662d56  mbs1/x86_64/lib64gd-devel-2.0.35-19.1.mbs1.x86_64.rpm
09b1c9c6e62fc636173aafac4a36f7b6  mbs1/x86_64/lib64gd-static-devel-2.0.35-19.1.mbs1.x86_64.rpm
7afba6bce1ba80c873bbe2df3bf89862  mbs1/SRPMS/gd-2.0.35-19.1.mbs1.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi.  The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security.  You can obtain the
GPG public key of the Mandriva Security Team by executing:

 gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

 http://www.mandriva.com/en/support/security/advisories/

If you want to report vulnerabilities, please contact

 security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID     Date       User ID
pub  1024D/22458A98 2000-07-10 Mandriva Security Team
 <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFTvkGgmqjQ0CJFipgRAvdqAKClI1iC86cjSTomQLFg54I7hA4YQgCePUiG
jNHFELZmnm3bDXG5HDNFcUk=
=jsQo
-----END PGP SIGNATURE-----

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород