Информационная безопасность
[RU] switch to English


Дополнительная информация

  Cводка уязвимостей безопасности в Web-приложениях (PHP, ASP, JSP, CGI, Perl)

  Multiple vulnerabilities in Vulcan theme for WordPress + WAF bypass

  [SECURITY] [DSA 3295-1] cacti security update

  CVE-2015-3443 XSS in Thycotic Secret Server version 8.6.000000 to 8.8.000004

  ManageEngine Asset Explorer v6.1 - Persistent Vulnerability

From:otr_(at)_bockcay.de <otr_(at)_bockcay.de>
Date:5 июля 2015 г.
Subject:CollabNet Subversion Edge insecure password change



# Vuln Title: The CollabNet Subversion Edge management frontend does not require
# current password upon password change
#
# Date: 28.06.2015
# Author: otr
# Software Link: https://www.open.collab.net/downloads/svnedge
# Vendor: CollabNet
# Version: 4.0.11
# Tested on: Fedora Linux
# Type: Insecure password change

# Risk: Medium
# Status: public/fixed
# Fixed version: 5.0

Timeline:

2014-10-09 Flaw Discovered
2014-10-20 Vendor contacted
2014-10-21 Vendor response
2014-12-08 Vendor fix proposal
2014-12-08 Extension of embargo to 19.4.2015
2015-05-04 Extension of embargo until release of version 5.0
2015-05-18 Release of version 5.0 and public disclosure

Summary:

The management frontend does not require the old password for changing the
password to a new one. An authenticated attacker may perform password setting
attacks via XSRF without knowing the current password. An attacker that stole a
Session ID (cookie) is able to gain persistent access by changing the password.

Fix proposal:

A password change should require the old password to be provided.

Vendor fix:

When a user is changing their password, they are now required to enter their
current password.

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород