Информационная безопасность
[RU] switch to English


DoS против str_ireplace в PHP
Опубликовано:13 февраля 2007 г.
Источник:
SecurityVulns ID:7219
Тип:локальная
Уровень опасности:
5/10
Описание:Вызов функции $Data = str_ireplace("\n", "<br>", $Data); может приводить к отказу приложения из-за однобайтового переполнения буфера.
Затронутые продукты:PHP : PHP 5.2
CVE:CVE-2007-0911 (Off-by-one error in the str_ireplace function in PHP 5.2.1 might allow context-dependent attackers to cause a denial of service (crash).)
Оригинальный текстdocumentThomas Hruska, [PHP-DEV] PHP 5.2.1 crashing Apache/IIS... (13.02.2007)

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород