Информационная безопасность
[RU] switch to English


Многочисленные уязвимости безопасности в библиотеке poppler
Опубликовано:13 октября 2010 г.
Источник:
SecurityVulns ID:11200
Тип:библиотека
Уровень опасности:
6/10
Описание:Различные уязвимости при разборе PDF.
Затронутые продукты:POPPLER : poppler 0.8
CVE:CVE-2010-3704 (The FoFiType1::parse function in fofi/FoFiType1.cc in the PDF parser in xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to 0.15.1, kdegraphics, and possibly other products allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via a PDF file with a crafted Type1 font that contains a negative array index, which bypasses input validation and which triggers memory corruption.)
 CVE-2010-3702 (The Gfx::getPos function in the PDF parser in xpdf before 3.02pl5, poppler 0.8.7 and possibly other versions up to 0.15.1, CUPS, kdegraphics, and possibly other products allows context-dependent attackers to cause a denial of service (crash) via unknown vectors that trigger an uninitialized pointer dereference.)
Оригинальный текстdocumentDEBIAN, [SECURITY] [DSA 2116-1] New poppler packages fix several vulnerabilities (13.10.2010)

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород