Информационная безопасность
[RU] switch to English


Многочисленные уязвимости безопасности в wpa_supplicant
дополнено с 5 мая 2015 г.
Опубликовано:21 июня 2015 г.
Источник:
SecurityVulns ID:14446
Тип:удаленная
Уровень опасности:
7/10
Описание:Переполнения буфера, DoS уязвимости.
Затронутые продукты:WPASUPPLICANT : wpa_supplicant 2.4
 GOOGLE : Android 5.1
CVE:CVE-2015-4146 (The EAP-pwd peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not clear the L (Length) and M (More) flags before determining if a response should be fragmented, which allows remote attackers to cause a denial of service (crash) via a crafted message.)
 CVE-2015-4145 (The EAP-pwd server and peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not validate a fragment is already being processed, which allows remote attackers to cause a denial of service (memory leak) via a crafted message.)
 CVE-2015-4144 (The EAP-pwd server and peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 does not validate that a message is long enough to contain the Total-Length field, which allows remote attackers to cause a denial of service (crash) via a crafted message.)
 CVE-2015-4143 (The EAP-pwd server and peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted (1) Commit or (2) Confirm message payload.)
 CVE-2015-4142 (Integer underflow in the WMM Action frame parser in hostapd 0.5.5 through 2.4 and wpa_supplicant 0.7.0 through 2.4, when used for AP mode MLME/SME functionality, allows remote attackers to cause a denial of service (crash) via a crafted frame, which triggers an out-of-bounds read.)
 CVE-2015-4141 (The WPS UPnP function in hostapd, when using WPS AP, and wpa_supplicant, when using WPS external registrar (ER), 0.7.0 through 2.4 allows remote attackers to cause a denial of service (crash) via a negative chunk length, which triggers an out-of-bounds read or heap-based buffer overflow.)
 CVE-2015-1863 (Heap-based buffer overflow in wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (crash), read memory, or possibly execute arbitrary code via crafted SSID information in a management frame when creating or updating P2P entries.)
Оригинальный текстdocumentUBUNTU, [USN-2650-1] wpa_supplicant and hostapd vulnerabilities (21.06.2015)
 documentUBUNTU, [USN-2577-1] wpa_supplicant vulnerability (05.05.2015)
 documentxing_fang_(at)_vulnhunt.com, [ALICLOUDSEC-VUL2015-001]Android wpa_supplicant WLAN Direct remote buffer overflow (05.05.2015)

О сайте | Условия использования
© SecurityVulns, 3APA3A, Владимир Дубровин
Нижний Новгород